Excel WYSZUKAJ dwa argumenty


Kolej i nietylko

Temat: Wyszukiwanie wartosci...
Tajan napisał(a): Wystarczy "opakowanie" funkcji WYSZUKAJ funkcja warunkowa JEZELI, np.: =JEŻELI(CZY.BŁĄD(WYSZUKAJ(wart_szuk;A1:A100;A1:A100));"";wart_wysw) Tak na marginesie, zamiast funkcji WYSZUKAJ lepiej jest używać WYSZUKAJ.PIONOWO lub WYSZUKAJ.PIONOWO. W twoim przypadku idealna bylaby rowniez funkcja PODAJ.POZYCJĘ. Funkcja WYSZUKAJ jest przestarzala i utrzymywana tylko dla zachowania zgodnosci z poprzednimi wersjami Excela. Dzieki...Jeszcze jedno...Funkcja znalazla argument w 1 tabeli z 3 (byly trzy tabele do przeszukiwania)...Jak zrobic zeby wartosc w przypadku znalezienia argumentu w 1 tabeli w miejsce funkcji wstawiamy wartość z A3 , jesli argument byl w 2 tabeli to wstawiamy wartosc z K19 itp....?
Źródło: topranking.pl/1209/wyszukiwanie,wartosci.php



Temat: Wyszukiwanie wartosci...
Witam! W artykule news:d98pbt$luk$1@nemesis.news.tpi.pl, niejaki(a): Krt z adresu <krzys@wp.plnapisał(a): Tajan napisał(a): | Wystarczy "opakowanie" funkcji WYSZUKAJ funkcja warunkowa JEZELI, | np.: | =JEŻELI(CZY.BŁĄD(WYSZUKAJ(wart_szuk;A1:A100;A1:A100));"";wart_wysw) | Tak na marginesie, zamiast funkcji WYSZUKAJ lepiej jest używać | WYSZUKAJ.PIONOWO lub WYSZUKAJ.PIONOWO. W twoim przypadku idealna | bylaby rowniez funkcja PODAJ.POZYCJĘ. | Funkcja WYSZUKAJ jest przestarzala i utrzymywana tylko dla | zachowania zgodnosci z poprzednimi wersjami Excela. Dzieki...Jeszcze jedno...Funkcja znalazla argument w 1 tabeli z 3 (byly trzy tabele do przeszukiwania)...Jak zrobic zeby wartosc w przypadku znalezienia argumentu w 1 tabeli w miejsce funkcji wstawiamy wartość z A3 , jesli argument byl w 2 tabeli to wstawiamy wartosc z K19 itp....? Nalezy zagnieżdzić funkcje JEŻELI, np: =JEŻELI(CZY.BŁĄD(WYSZUKAJ(wart_szuk;A1:A100;A1:A100));JEŻELI(CZY.BŁĄD(WYSZU­KAJ(wart_szuk;B1:B100;B1:B100));JEŻELI(CZY.BŁĄ D(WYSZUKAJ(wart_szuk;C1:C100;C1:C100));"";F20);K19);A3) Uwaga! W Excelu można zagnieżdżać do siedmiu funkcji. Powodzenia Tajan
Źródło: topranking.pl/1209/wyszukiwanie,wartosci.php


Temat: Formatowanie warunkowe
Witam! Tajan wrote: Po prostu Excel nie rozumie, że pierwszy argument funkcji ADRES, to numer wiersza. Traktuje go jako zwykłą liczbę i nie stosuje  odwołań względnych przy kopiowaniu. Trudno zresztą oczekiwać, ... Tajan Jak zwykle nie zawiodlem sie!!! Z tego co widze, to dziala to na zasadzie funkcji wyszukaj.pionowo, ale w innej postaci. Numer wiersza faktycznie sie kopiuje - za co bardzo dziekuje....
Źródło: topranking.pl/1210/formatowanie,warunkowe.php


Temat: Excel - wyszukaj.pionowo ?
Witam Mam problem, jak w Excelu przy pomocy dostępnych funkcji zrealizować wyszukiwanie w tabeli wartosci tak jak w wyszukaj.pionowo ale dla dwu argumentow. Chodzi mi np o pobranie daych z kolumy...
Źródło: topranking.pl/1210/excel,wyszukaj,pionowo.php


Temat: Excel - wyszukaj.pionowo ?
Witam! Mam problem, jak w Excelu przy pomocy dostępnych funkcji zrealizować wyszukiwanie w tabeli wartosci tak jak w wyszukaj.pionowo ale dla dwu argumentow. Chodzi mi np o pobranie daych z kolumy ... y ;D1:D100;0));"Brak";INDEKS(C1:C100;PODAJ.POZYCJĘ(x & y ;D1:D100;0);1)) W przypadku gdyby taka dodatkowa kolumne mozna bylo dodac z lewej strony listy, wtedy mozna ja uproscic wykorzystujac Wyszukaj.Pionowo: =JEŻELI(CZY.BRAK(PODAJ.POZYCJĘ(x  & y ;A1:A100;0));"Brak";WYSZUKAJ.PIONOWO(x & y ;A1:D100;4;FAŁSZ))...
Źródło: topranking.pl/1210/excel,wyszukaj,pionowo.php


Temat: Auto-uzupełnianie wiadomości w pliku korzystając z danych 2 innych...
pytanie czy potrzebny jest Ci do tego trzeci plik, możesz to zrobić w pliku 1.xls np. w kolumnie E w komórce E2 wpisując funkcję: = wyszukaj.pionowo(A2;'[2.xls]arkusz1'!$A$2:$D$26;4;Fałsz) Zakres A2:D26 oczywiście przykładowy, należy ... pełną ścieżkę dostępu do pliku 2.xls. Funkcja wyszukaj pionowo działa trochę tak jak kwerenda wyszukująca w accesie, tzn to co jest w komórce A2 szuka w pierwszej kolumnie zakresu który jest drugim argumentem i zwraca wartość z nr kolumny który podałeś jako trzeci argument funkcji. Ostatnim argumentem (w tym przykładzie Fałsz) decydujesz czy wyszukujesz dokładnego dopasowania (wartość właśnie Fałsz) czy przybliżonego (prawda...
Źródło: topranking.pl/1210/auto,uzupelnianie,wiadomosci,w,pliku.php


Temat: help me
Witam! Potrzebuję stworzyć formularz wyszukujący z listy wybrany element i wartość do niego przypisaną w sąsiedniej kolumnie dla EXCEL 2007. Np. mamy listę wpłat dokonanych przez wiele osób i potrzebujemy formuły, która pozwoli nam szybko znaleźć, ile wpłaciła wybrana przez nas osoba. Próbowałem zastosować następującą formułę: =WYSZUKAJ.PIONOWO(D2;A2:B6;2;FAłSZ). D2-z tej komórki zostanie pobrana wartość poszukiwana, 2- kolumna zakresu przeszukiwanego, z której zostanie pobrana wartość, FAłSZ- określa, że wartości w pierwszej kolumnie zakresu przeszukiwanego(czyli nazwiska) nie muszą być posortowane rosnąco. Pominięcie ostatniego argumentu oznacza przyjęcie wartości domyślnej PRAWDA. Wówczas funkcja WYSZUKAJ.PIONOWO na tablicy nieposortowanej może dawać błędne wyniki. Efekt jest połowiczny, gdyż wszystko jest prawie ok, z tym jednak, że zostaje zaznaczony cały przeszukiwany przeze mnie obszar (A2:B6), podczas gdy ja chcę wyszukać tylko dany element,...
Źródło: topranking.pl/1210/help,me.php


Temat: wszukaj ? wyszukaj.pionowo ? indeks ?
... excel wyszukiwal poprawnie. podpowiedzi mile widziane. Zapewne pamiętasz o tym, że jeżeli uzywasz WYSZUKAJ.PIONOWO/POZIOMO na nieposortowanych danych, to ostatnim argumentem tej funkcji powinna byc wartość FAŁSZ? Natomiast funkcja WYSZUKAJ z zasady...
Źródło: topranking.pl/1210/wszukaj,wyszukaj,pionowo,indeks.php


Temat: błąd funkcji Szukaj()
Tajan wrote: Korekta! Funkcja WYSZUKAJ należy do grupy funkcji uznawanych za przestarzałe i utrzymywana jest tylko dla zapewnienia zgodności z poprzednimi wersjami Excela. Zapewne posiada jakieś ograniczenie nie pozwalające jej na wyszukiwanie wartości, gdy wartość jest pobierana z obszaru przeszukiwanego. Nie to nie to :-) Funkcja WYSZUKAJ prawidłowo działa tylko na obszarze posortowanym. Jeżeli dane posortujesz wg nazwisk, to będzie OK. Ale to jeszcze jeden argument za zaprzestaniem jej używania. Sorry, że tak na raty, ale tej funkcji nie używam od lat. Tajan
Źródło: topranking.pl/1211/blad,funkcji,szukaj.php


Temat: Pobieranie wartości z zamkniętego skoroszytu
Mam kolejny problemik. W jaki sposób z poziomu kodu VBA przeszukiwać można wiersze skoroszytu? Idealną metodą jest uzycie funkcji WYSZUKAJ.POZIOMO. Nie mam pomysłu jak to  zrobić w VBA. Na razie buduje programowo funkcję W.P, wklejam ją do komórki.  Dalej excel sam jakoś liczy (czasem trzeba mu pomóc :)). Czy ktoś zechce mi podpowiedzieć, jak się zabrać do tego? Użyj metody Vlookup obiektu WorksheetFunction. Metoda ta jest odpowiednikiem funckji arkusza WYSZUKAJ.PIONOWO - ma dokładnie takie same argumenty, z tym, że zamiast adresów komórek musisz podawać obiekt Range. Przykładowo funckja zapisana w arkuszu w ten sposób: =WYSZUKAJ.PIONOWO(C1;A1:B11;2;FAŁSZ) W VBA możesz użyć w ten sposób: jakaś_wartość = WorksheetFunction.VLookup(Range("C1"), Range("A1:B11"), 2, False)
Źródło: topranking.pl/1309/pobieranie,wartosci,z,zamknietego,skoroszytu.php


Temat: Excel
Excel Mam wielką prośbę. Mógłby mi ktoś napisać jak wykonać te zadania. **Dokonałeś pomiarów wszystkich pomieszczeń w mieszkaniu i otrzymałeś następujące dane: Pomieszczenie: Szerokość [m]: Długość [m]: Pokój 1 3,3 4,25 ... Wyszukaj za pomocą odpowiednich funkcji arkusza powierzchnię najmniejszą i największą. **Sporządź w arkuszu tabelę obliczającą wartości funkcji a następnie sporządź jej wykres w przedziale argumentów od -10 do 10 z rozsądnie...
Źródło: forum.gazeta.pl/forum/w,34,93753920,93753920,Excel.html


Temat: Adres komorki w Excel'u
blad, ze argumenty nie zostaly jeszcze policzone (choc powinny bo sa nad funkcja lub(i) po lewej jej stronie. Moze ktos wie jak to sie robi. Albo jak liczby z tego zakresu...
Źródło: topranking.pl/1414/adres,komorki,w,excel,39,u.php


Temat: excel-formuly
Próbowałem tę formułe uogólnić, tzn. w komórkach są wartości np.: a;b;c;d,c,b itd. i tablica wzorcowa a odpowiada 1, b=2, c=2, d=3 no i formuła: {=SUMA(WYSZUKAJ.PIONOWO(A1:A5;C1:D4;2))} i teraz tak jeżeli ta formuła ... akcji, a następnie zostaną dodane do siebie wyniki tych obliczeń. Naciśnij klawisze CTRL+SHIFT+ENTER. --------------- Obliczanie wielu wyników. Niektóre funkcje arkusza zwracają tablice wartości albo wymagają tablicy wartości jako argumentu. Aby obliczyć wiele wyników za pomocą formuły tablicowej, trzeba wprowadzić tablicę w zakresie komórek, który ma tę samą liczbę wierszy i kolumn, co argumenty tablicowe. Zaznacz zakres komórek, w którym chcesz wprowadzić formułę ... wprowadzasz formułę tablicową do jednej tylko komórki, to Excel domyślnie przyjmuje wszystkie argumenty tablicowe funkcji jako elementy tablicy. Czyli w Twoim przypadku bedzie to jakby suma komórek, w których wpisane sa następujące formuły: =WYSZUKAJ.PIONOWO(A1;C1:D1;2) =WYSZUKAJ.PIONOWO(A2;C2:D2;2) =WYSZUKAJ.PIONOWO(A3;C3:D3;2) =WYSZUKAJ.PIONOWO(A4;C4:D4;2) 2) Jeżeli wprowadzasz formułę tablicową do kilku komórek, to Excel domyślnie przyjmuje wszystkie argumenty tablicowe funkcji jako tablice. Czyli w Twoim przypadku bedzie to jakby suma komórek, w których wpisane sa następujące formuły: =WYSZUKAJ.PIONOWO(A1;C1:D4;2) =WYSZUKAJ.PIONOWO(A2;C1:D4;2) =WYSZUKAJ.PIONOWO(A3;C1:D4;2) =WYSZUKAJ.PIONOWO(A4;C1:D4;2) szczerze mówiąc to nie bardzo czuję formuły tablicowe Formuły tablicowe są często bardzo pomocne, szczególnie jeżeli zależy nam, aby ... w funkcji zmieniającej tablice na pojedynczą wartość, takich jak SUMA, ŚREDNIA, MIN czy MAX. Ja dodatkowo staram także się unikać stosowania funkcji, których argumentami są tablice, jak w twoim przykładzie.
Źródło: topranking.pl/1209/55,excel,formuly.php